UPDATE 03: This is to notify you that the service impairment affecting the services listed below has been resolved. Please see below for more details.
Description: GSM Data services
Incident case number:148165
If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Jul 02, 2025 - 09:07 UTC
Update
UPDATE 02: Aeris engineers are working with the carrier partner to resolve this issue. We will provide more information as soon as it becomes available. Please see below for the services that are impacted.
Description: GSM Data services
Incident case number:148165
If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Jul 02, 2025 - 08:38 UTC
Update
Update01: Aeris engineers are actively investigating the matter in collaboration with our carrier partner. Further updates will be shared as soon as more information becomes available. No ETR is available at this time. Please see below for the services that are impacted.
Description: GSM Data services
Incident case number:148165
If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Jul 02, 2025 - 07:38 UTC
Investigating
This is to notify you that Aeris' monitoring system has detected a potential service degradation in GSM data services. Aeris engineers are engaged in isolating the problem and will provide further updates as they become available. Please see below for the services that are potentially impacted.
Description: GSM Data services
Incident case number:148165
If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Jul 02, 2025 - 06:35 UTC
This incident affected: Global GSM Services (UK, European and African Markets) (Data).