Incident Notification

Incident Report for Aeris Connectivity Service Status

Update

UPDATE: Our carrier partner has shared that due to government-imposed restrictions following recent incidents during the ongoing elections, internet services in Tanzania are currently unavailable. Services will be restored as soon as the restrictions are lifted. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 30, 2025 - 15:11 UTC

Update

UPDATE: This is to provide you an update that our team continue to collaborate with our partners to monitor the situation and to provide further updates once available. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 30, 2025 - 06:56 UTC

Update

Update: This is a further update regarding the ongoing Data browsing issue majorly for Tanzania inbound and outbound subscribers. Our carrier partner has confirmed that the issue, impacting data browsing and some SMS deliveries, is due to a wider internet service disruption in Tanzania. The affected roaming partner is investigating. There is currently no estimated time for resolution. We are closely monitoring the situation and will provide further updates as they become available.

Description: 2G / 4G Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 30, 2025 - 05:20 UTC

Update

This is to provide you an update on this trouble. We continue to see the impairment reflected in the service dashboards. We are reaching out to the carrier partner again inquiring about an update from their roaming partner in Tanzania. We will provide additional updates as new information is obtained.
Posted Oct 30, 2025 - 00:52 UTC

Update

Our carrier partner has confirmed an ongoing issue with their local roaming partner in Tanzania. They continue to work closely with the local partner to identify and resolve the problem. We are actively collaborating with them to monitor progress and will provide further updates as soon as new information becomes available. At this time, no estimated time to resolution (ETR) is available. Please refer to the list below for impacted services.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 23:38 UTC

Update

UPDATE 7: Carrier partner has acknowledged issue at local roaming partner in Tanzania. We continue to collaborate with our partners to monitor the situation and to provide updates. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 21:44 UTC

Update

UPDATE 6: Carrier partner has acknowledged issue at local roaming partner in Tanzania. We continue to collaborate with our partners to monitor the situation and to provide updates. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 19:58 UTC

Update

UPDATE 5: Carrier partner has acknowledged issue at local roaming partner in Tanzania. We continue to collaborate with our partners to monitor the situation and to provide updates. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 18:29 UTC

Update

UPDATE 4: Aeris carrier partner continues to work with impacted roaming partner in Tanzania. We continue to collaborate with our partners to monitor the situation and to provide updates. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 17:01 UTC

Update

UPDATE 3: Aeris carrier partner have confirmed an impact with roaming partner in Tanzania. We continue to collaborate with our partners to monitor the situation and to provide updates. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 15:33 UTC

Update

UPDATE 2: Aeris engineers have engaged our carrier partner and continue to troubleshoot the issue. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 14:26 UTC

Identified

UPDATE 1: Aeris engineers have engaged our carrier partner and continue to troubleshoot the issue. No ETR is available at this time. Please see below for the services that are impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 13:12 UTC

Investigating

This is to notify you that Aeris' monitoring system has detected a potential service impairment. Aeris engineers are engaged in isolating the problem and will provide further updates as they become available. Please see below for the services that are potentially impacted.

Description: 2g / 4g Data sessions in Tanzania

Incident case number: 155775

If you have any additional questions, please contact support@aeris.net and reference the case number above.
Posted Oct 29, 2025 - 12:15 UTC
This incident affects: Global GSM Services (UK, European and African Markets) (Data).