Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 21, 2026 - 03:00 UTC
Scheduled
This is to notify you that Aeris engineers will perform maintenance beginning on August 21, 2026, at 3:00 AM UTC to deploy service enhancements. The maintenance window will last up to five hours, from 3:00 AM to 8:00 AM UTC, followed by a 24-hour monitoring period ending on August 22, 2026, at 8:00 AM UTC.
During the maintenance window on August 21, 2026, between 3:00 AM UTC and 8:00 AM UTC, customers using Dual-Mode A-LH Service, Fusion NA IoT Service, Fusion Global IoT Service, and Global GSM Service may experience brief degradation of VPN, Data, SMS, and Voice services for up to 30 minutes in the United States market only. Customers in the UK, Europe, and Africa will not be impacted.
Please see below for additional details.
Maintenance case reference number: 183144 / IOTCHG-10738
Posted Aug 11, 2026 - 18:19 UTC
This scheduled maintenance affects: Dual-Mode A-LH Service (Data, SMS, Voice), Fusion NA IoT Service (Data, SMS), Fusion Global IoT Service (Data, SMS, Voice), and Global GSM Services (US Market) (Data, SMS, Voice).